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 Using the Hidden Gems 

These hidden gems are designed to save you clicks, save you page refreshes, and, ultimately, save you 
time.  Although it may be tempting, don’t try to learn them all at once! If you do then it’s likely you’ll 
end up wasting time as you try to think of the “right” thing to do in a given situation. Instead, pick a few 
tips and practice until you’ve mastered them. Then choose some more and practice those. Eventually 
you’ll learn them all (and probably have some of your own to add to the list). 

 Making Use of My Job Queue 

My Job Queue lets you start a report now and get its results later. There are two great uses for this 
feature: 

1. Kick-off multiple jobs at once rather than running them sequentially 
2. Access the results of a previously run job without having to re-run the report 

EXAMPLE 

In addition to your normal workload, today you must also run the “Report Cards,” “Monthly Register,” 
and “Grade Point Averages” reports for the high school. You quickly run each report without waiting for 
any of the jobs to finish. Then you continue with you other work. Later you open My Job Queue and 
print the three PDFs. Twenty minutes later the principal asks you for a copy of the report card PDF. 
Rather than running the report again you simply download the PDF from My Job Queue and send it via 
email. 

 Don’t Confirm the Confirmation 

Aspen displays confirmation messages when you save a record or an operation completes. Although it’s 
important to know the action was successful it’s not 
important to click the “OK” button – it does nothing 
except close the message window. You’ll save yourself 
time by leaving the message window alone, it will 
disappear after the next page refresh. 

  



v3.0 ASPEN’S HIDDEN GEMS 

 

2 TOP SECRET | X2 Development Corporation 

 

 Simplified Date & Time Entry 

Aspen automatically formats dates so you don’t have to. That means fewer keystrokes and faster data 
entry. There are also shortcuts that save you from typing any date at all (and from reaching for a 
calendar). 

Date Format Results 

MMDDYY 
Date formatted as M/D/YYYY 
(123110  12/31/2010) 
(010199  1/1/1999) 

M/D/YY 
Date formatted as M/D/YYYY – year converted to 4 digits 
(12/31/10  12/31/2010) 

t Today’s date 
+N where N is some digit between 0 and 99 N days after today’s date 
-N where N is some digit between 0 and 99 N days before today’s date 

Aspen converts a two-digit year to a four-digit year via the following rule: 

• If the year is between 0 and 28 then the century is assumed to be 2000 

• If the year is greater than 28 then the century is assumed to be 1900 

Just like with dates, Aspen automatically formats times so you don’t have to. Again, that means fewer 
keystrokes and faster data entry. 

Time Format Results 

HMM 
Time formatted as H:MM AM/PM 
(344  3:44 PM) 
(1100  11:00 AM) 

HMMA 
Time formatted as H:MM AM 
 (344A  3:44 AM) 

HMMP 
Time formatted as H:MM PM 
 (1100p  11:00 PM) 

If not specified, Aspen will determine AM versus PM via the following rule: 

• If the hour is between 6 and 11 then AM is used 

• If the hour is 12 or less than 6 then PM is used 
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 “Dummy” Field Sets 

Often times you’ll find yourself needing to view one or more fields on a list of records but none of the 
existing field sets contain those fields. In order to view those extra fields you must choose one of two 
options: 

1. Edit an existing field set and add the fields 
2. Create a new field set that contains the fields 

Sometimes these options may be appropriate, especially if the fields you’re adding are fairly common 
and useful to a broad group of users. However, if you’re interested in some obscure fields, particularly 
for just a short period of time, then neither option really suits your needs. 

Editing an existing field set isn’t a good idea because it’s likely to be shared by multiple users and you 
don’t want to change the columns they see – even if you “clean up” and remove the fields when you’re 
done (which is extra work). Creating a new field set isn’t a good idea either because over time you’ll 
wind up with a list of dozens of entries on your Field set menu that make it difficult to find the one you 
need. 

Instead, create a personal “dummy” field set based on a copy of the default field set and add the 
necessary fields. Next time you’re on that list and need to view other fields just edit your dummy field 
set. It’s a good idea to use a standard naming convention for your dummy field sets so you can quickly 
recognize them on the menu. Some examples are “Dummy Fields,” “My Fields,” or “Quick Fields.” 

 Ad Hoc Filters with CTRL+F 

Queries and snapshots are great ways to filter a list but sometimes it’s more appropriate to make an ad 
hoc selection by using CTRL+F multiple times to select a bunch of records followed by either Show 
Selected or Omit Selected. This gem is very useful when combined with the Filter Your List to Focus 
Your Efforts gem. 

Remember that CTRL+F finds records based on the list’s primary sort field. You must change the list’s 
sort order to find records based on values in another field. 

EXAMPLE 

You submitted a data extract to the state DOE. In return you received a list of ten SASIDs that 
correspond to students with errors in the submission. You go to the District view, Student tab and 
change the sort order to SASID. You press CTRL+F, type an ID number, and press enter for each of the 
ten values (no mouse needed!). You then choose Show Selected from the Options menu to show just 
those ten students. Now it’s time to start making corrections! 
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 The Benefits of Omit Selected 

Show Selected is always followed by Omit Selected on the Options menu but most users have probably 
never used that second option. There are two use cases for Omit Selected. The first, more obvious case 
is when it’s quicker to select the records you don’t want on the list rather than the ones you do want. 
The second, more subtle case is when you plan to add records to the list after making the ad hoc filter. 
When you add a record to a list after using Show Selected, the new record won’t appear in the results 
because it’s not in your original selection. On the other hand, when you add a record to a list after using 
Omit Selected, the new record will appear in the results because it hasn’t been excluded. 

EXAMPLE 

You’re on the Student > Attendance side-tab and are looking at a list of 20 records. Since you only need 
the 15 most recent, you select the last 5 and choose Omit Selected from the Options menu. Then you 
create an absence for today. Your list includes that new record and now shows 11 records. 

 Filter Your List to Focus Your Efforts 

Filtering a list to just the records you need to work with has numerous benefits: 

• Your attention is focused on just the necessary records 

• Your filter is maintained even when you leave the list and come back later preventing the need 
for finding the records again (useful in combinations with the Changing Views for Faster 
Navigation gem) 

• Moving from one record’s detail page to another is easy with the record navigation buttons 

• 9 times out of 10 the list will load quicker when there are fewer records 
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 Adding Prompt Queries to the Filter Menu 

Prompt queries are one of the best ways to save time – a single prompt query can give you the results of 
many hard-coded queries. Although it does take a few extra steps to create a prompt query, the long 
term savings more than compensate. Add these prompt queries to your Filter menu for quick access (it’s 
best to order your filters so that the ones you use most often are near the top). 

When saving a prompt query remember to use the question mark character (?) in the name. This 
character acts as a token and ensures that the value you selected when running the query will be 
displayed on the list page. 

EXAMPLE 

One of the most common queries run in Aspen is to find the students in a particular grade level. You can 
find these students with just a couple of clicks by following these steps: 

• Setup 
o Create an advanced query that prompts for grade level 
o Save the query and call it “Grade ?” 
o Add it to your Filter menu 

• Usage 
o Select “Grade ?” from your Filter menu 
o Select the desired grade level and click Submit 

 Select “All Records” on the Query, Not the List 

Don’t select “All Records” from your Filter menu if your next step will be to run a query. Instead, select 
“All Records” in the Search based on list on the Query window. Not only does this save a page refresh, it 
also prevents a potentially large list of records from being loaded unnecessarily. 

EXAMPLE 

Imagine you’re on the Student tab in the District view and have filtered the list to students whose last 
name begins with C. Now you want to view students whose last name begins with M. Don’t select “All 
Records” from the Filter menu – it’s unnecessary and it loads the entire list of students in the database. 
Instead, select Query from the Options menu, enter your criteria, and choose “All Records” from the 
Search based on list at the bottom of the window. 
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 Date Variables in Advanced Queries 

Advanced queries allow you to use variables in your criteria rather than constant (a.k.a., hard-coded) 
values. There is a rich set of variables available for date fields such as today, yesterday, first of month, 
last of month, etc. Creating a single saved query that uses one of these variables will save you from 
having to create the same old hard-coded query again and again. 

EXAMPLE 

Every morning your secretaries want to see the list of students absent that day. The Attendance > Daily 
Office side-tab and reports like “Attendance Bulletin” aren’t sufficient because the secretaries like to 
view all related information for those students like contacts, conduct, prior attendance, etc. They need a 
query that can be run from the Student tab. Rather than running a simple query every morning with 
today’s date, you save the following advanced query and add it to the secretaries’ Filter menu: 
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 Fast Loading Global Lists 

Global Lists are a great tool for accessing all the records in a table but the list itself can take some time 
to load for large tables like Student Transcript and Student Attendance. This can be annoying if you all 
you need to do is perform a query that will return a much smaller subset of records. You can make 
Global Lists load much quicker by making the default filter a query or snapshot with very few records. 

EXAMPLE 

You access the Global List for Student Attendance once a week to export attendance records for 
students across the district. Since that table contains several million records the page takes quite some 
time to load. Once the page is loaded you simply query for records created since last Monday’s date 
(which results in less than 1,000 records). In order to avoid that initial load time for a list of records you 
never use, you save a simple query called “Default Filter” that has a single criteria for “Date equals 
1/1/2000” and set it as the first item in your Filter menu. Next time you visit Global List for Student 
Attendance you load 0 records (school’s not in session on New Year’s Day) – much, much faster than 
several million. 

 Selecting 397 Records in a Single Click 

The easiest way to select a strange number of records in a list (like 397 in the title of this gem) is to set 
your Records per page preference to that value and then click the top checkbox in the list to select all 
records on that page. 

 Click ‘N Go 

“Click ‘N Go” is a way to save a page refresh when accessing side-tab information for the selected record 
in a list. You use Click ‘N Go by selecting the checkbox next to a record in the list and then clicking the 
desired side-tab rather than clicking the link for the record (which causes a page refresh as the first side-
tab is opened) and then clicking the desired side-tab. 

EXAMPLE 

Imagine you want to view the list of contacts for a particular student. You find the student and either: 

A. Click the student’s name (which opens the Details side-tab) and then click the Contacts side-tab 
B. Select the checkbox next to the student’s name and click the Contact side-tab. 

Option B is the Click-N-Go option and saves the intermediate page refresh for the detail page. 
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 Remember: The Last Selected Record is Remembered! 

Aspen remembers the last record you selected on a list. That means the next time you visit a list and 
want to view details about that record all you need to do is click the desired side-tab – there’s no need 
to find the record first. 

EXAMPLE 

Go to the Student tab, find John Smith, and view his record by clicking the Details side-tab. Now go to 
the Staff tab, find his homeroom teacher Anne Brown, and view her record by clicking the Details side-
tab. If you want to later view the contacts for John Smith all you have to do is click the Student tab and 
Contacts side-tab – there’s no need to find John Smith’s record on the list. 

 Sorting a List to Find Missing Relationships 

Getting a list of records missing a particular relationship requires a direct SQL query – a task that is 
beyond the technical skills of most users. An alternative way to get the same results is to sort the list by 
a field on the related table – records missing that relationship will appear at the top of the list and can 
easily be selected (see the Selecting 397 Records in a Single Click gem for help with the selection). 

EXAMPLE 

To find students who don’t have a value set for Next School requires this direct SQL* query: 

SELECT * FROM STUDENT WHERE STD_SKL_OID_NEXT IS NULL 

Formulating this query is a daunting if not impossible task for most users. A much simpler alternative is 
to sort the student list by Next School > Name. Students without a Next School will appear at the top of 
the list. 

* User will often attempt to find such students with a simple query that has a single criteria for “Next 
School > Name is not empty.” However, because of the way Aspen builds the underlying query the results 
will almost always be empty (and never be correct). With the simple query, Aspen first looks for students 
who do, in fact, have a next school but that related school record happens to have an empty name. 
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 Changing Views for Faster Navigation 

The Change View menu is a great way to save page refreshes. Aspen remembers the last tab and side-
tab you visited in each view. We can use this to our advantage and with a single page refresh navigate 
between two side-tabs under different top-tabs (an operation which normally takes at least two page 
refreshes, sometimes more). 

EXAMPLE 

Imagine you want to customize the default template for the Student > Details page. You make your 
changes in the District view on the Tools > Templates > Design page. Then to test your changes you do 
the following: 

• Click the Student tab (page refresh) 

• Click the Details side-tab (page refresh) 

• Determine more changes are necessary 

• Click the Tools tab (page refresh) 

• Click the Templates side-tab (page refresh) 

• Click Design on the side-tab (page refresh) 

• Make some edits, repeat steps to view your changes 

Bottom line – lots of page refreshes! Instead, start in the School view on Student > Details. Then switch 
to the District view, Tools > Templates > Design. Now with a single page refresh via the Change View 
menu you can toggle between the student detail page in the School view and the template editor in the 
District view. 

 Choosing the Right View for the Right Job 

With the previous tip we learned how to save page refreshes with the Change View menu. That tip 
combined with a list of complimentary views will help you streamline numerous tasks. Choose two views 
such that the primary view is where you’ll be doing the work – changing a template, customizing a 
report, running an export, etc. – and the secondary view is where you’ll be viewing the results. 

EXAMPLES 

Task Primary View Secondary View 

Editing a template 
District 
(Tools > Templates > Design) 

School 
(wherever template is displayed) 

Editing a report 
District 
(Tools > Reports > Details) 

School 
(wherever report is run) 

Running/validating EPIMS 
District 
(Tools > Exports > Details) 

Personnel 
(Staff > Details) 
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 Never Leave The Keyboard 

Constantly reaching for the mouse slows data entry. Many “mouse operations” have keyboard 
equivalents that will save you time. 

WEB PAGE / FORM KEYSTROKES 

Keystroke Action 
TAB Moves to the next field/link on the page 
SHIFT+TAB Moves to the previous field/link on the page 

ENTER on a selected link or button 
Equivalent to clicking the link or button with the mouse (for 

example, TAB to a  icon and press ENTER to open the pick list) 

ASPEN PICK LIST KEYSTROKES 

Keystroke Action 
UP arrow Selects the next record in the list (will move to next page) 
DOWN arrow Selects the previous record in the list (will move to previous page) 
CTRL+F Selects the record most closely matching the search value 
ENTER Equivalent to clicking the “OK” button with the mouse 

GENERAL WINDOWS KEYSTROKES 

Keystroke Action 
CTRL+A Select all 
CTRL+C Copy 
CTRL+X Cut 
CTRL+P Paste 
CTRL+S Save (in almost every Windows application except Aspen!) 
ALT+TAB Switch between open Windows 
 

 Customizing Reports Like a Pro 

Whenever you customize a report you’ll need to (A) test it and (B) debug it when/if it throws an 
exception. After making your changes to a report you can run it directly from the detail page by 
choosing Run… from the Options menu (you must compile and save you changes first). If your report 
throws an exception then you can view the details of the error simply by clicking Logs on the side-tab 
and reviewing the first record in the list. 

Note: Some reports do not support the Run… option. Such reports must be run from whatever page 
they appear in the system. Use the Choosing the Right View for the Right Job gem to minimize page 
refreshes. 
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 Gender-Specific Report Formatting 

Form letters like the “Absence Letter” and “Suspension Letter” typically contain phrases such as “Your 
son/daughter has violated code…” and “…as a result he/she must…” You can make these reports more 
professional by using simple Java syntax to select the correct word (son vs. daughter, he vs. she) based 
on the student’s gender code. That syntax looks like this: 

"M".equals($F{student.person.genderCode}) ? "son" : "daughter" 

Note that you may have to change the field name (the portion highlighted in red) based on the 
particular report you’re using. 

This Java syntax is referred to as a ternary statement and follows the pattern: 

CONDITION_TO_CHECK ? TRUE_RESULT : FALSE_RESULT 

The first portion, from the beginning of the line to the question mark, is a condition – something that 
evaluates to either true or false. The second portion, from the question mark to the colon, is what to do 
if the condition is true. The third portion, from the colon to the end of the line, is what to do if the 
condition is false. 

The above example is checking to see if the student’s gender code is equal to the letter “M”. If so then 
“son” is displayed, if not then “daughter” is displayed. A complete sentence embedding that syntax 
would look like: 

"Your " + ("M".equals($F{student.person.genderCode}) ? "son" : "daughter") + " has 
violated school code..." 

 Not-So-Mass Update 

Before performing a mass update on an entire list of records, try it first on just one or two records. This 
is particularly useful when mass updating with another field or an expression – what you think will 
happen may not actually be what does happen. Undoing a mistake for one or two records is much easier 
than fixing hundreds or thousands of records. 

It’s also a good idea to test other “large scale” operations on small selections (read: one or two records). 
Such operations include preparing grade input, posting grades, merging drop/adds, calculating averages, 
calculating credits, creating user accounts, populating homerooms… You get the idea. 
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 Force That Mass Update to Go Faster 

Selecting the Force save checkbox on a mass update (only available when using advanced mode) can 
significantly reduce the amount of time to complete the operation because the updated records won’t 
be validated. 

 

Of course, you may want or need to validate your mass update so use this option when appropriate. 

 Poor Man’s Export 

Have you ever wanted to get data from Aspen into Microsoft Excel but don’t want to go through the 
hassle of creating an export? Or perhaps you don’t have access to create or run exports in the first 
place? Remember that Quick Report has an option to format output as a CSV file. That CSV file can be 
saved locally and opened in Excel or other spreadsheet applications. Combine Quick Report’s CSV option 
with Global Lists and you can virtually export the entire database without writing a single line of code! 

 Pain-Free Backup and Restore 

There’s always the ability to retrieve data from a backup if necessary.* However, the most recent 
backup may be several hours old and restoring data from it may require significant resources in terms of 
time and/or money. You can use one of the following simple strategies to backup and restore (if 
necessary) data without involving your database administrator or X2 Technical Services. 

Strategy 1: Saving Values in a Temporary Field 

• Steps to backup: 
o Define temporary field in Data Dictionary 
o Mass update temporary field with values from original field 

• Steps to restore (if necessary): 
o Mass update original field with values from temporary field 

• Clean up: 
o Reset temporary field when done 
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Strategy 2: Saving Values via Quick Report 

• Steps to backup: 
o Run a Quick Report in CSV format with identifying field(s) and fields to backup 
o Save CSV file locally 

• Steps to restore (if necessary): 
o Define import that matches on identifying field(s) and updates other fields 
o Run import with saved CSV file 

• Clean up: 
o None 

Strategy 1 is quicker to implement but gets cumbersome if you need to backup multiple fields. 

EXAMPLE 

You are about to recalculate GPAs for all students at the high school. You think you have everything 
configured properly but you’re not 100% sure. You make a quick backup of the existing GPA values by 
defining a field called “Temp GPA” on the Student table and mass updating it with the field that contains 
the actual value. If you find the recalculation has gone awry you can easily restore the original values by 
performing a mass update in the reverse order (temporary field to actual field). 

* X2 manages backups for all districts hosted at our data center. Districts hosting Aspen in house are 
responsible for their own backups. At an absolute minimum, X2 recommends a full database backup 
once a day. 

 Scheduled Jobs as Regular Backups 

Reports like “Enrollment Breakdown” and “District Enrollment” give a snapshot of student demographic 
data at a single point in time. Running these reports for dates in the past may be impossible (the report 
may not have such an option) or give inaccurate results (student enrollment information is incomplete). 
A quick solution to this problem (besides customizing the report or manually correcting enrollment data) 
is to create a scheduled job for the report that saves multiple results and runs daily, weekly, monthly, 
etc. The next time your superintendent asks for enrollment totals from last December you can easily 
download the appropriate file from the job’s results. 
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 Quick Report Summaries 

Quick Report’s “Summary” report type is intended to display the number of records within the selected 
group. However, the output isn’t formatted in the nicest of ways. A much better format can be achieved 
by setting a COUNT statistic on the group field rather than using group totals. 

EXAMPLE 

You want a Quick Report to show the total number of students in each grade level at your school. You 
set the report type to “Summary” and select the Grade level field. When you get to Step 5 – Totals and 
Statistics you choose the options below but the results aren’t what you want: 
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If instead on Step 5 – Totals and Statistics you choose the options below you get the results you want: 

 

 

 

 

 

 

 

 

 Reference Code Cleanup 

Aspen has powerful tools for managing reference data – from building a list of codes to renaming codes 
to merging multiple codes into a single value. These tools are fully documented in the online help but 
are often overlooked and have therefore been included as “forgotten” if not “hidden” gems. 

• Build Reference (Options menu item; District view, Admin > Data Dictionary > Tables > Fields > 
Details) – builds reference codes for each of the unique values currently in the selected field, 
creates a reference table for the field is one does not already exist 

• Merge Codes (Options menu item; District view, Admin > Data Dictionary > Reference > Codes) – 
combines two or more codes into a single code, optionally updates existing records 

• Renaming a code (triggered upon save; District view, Admin > Data Dictionary > Reference > 
Codes > Details) – optionally updates existing records to use the new version of the code 
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 Multiple Browsers the Safe Way 

Occasionally you may have the need to view two separate pages in Aspen on your screen at the same 
time. You might be tempted to simply open another browser window, login to Aspen again, and 
navigate to the other page. However, you may notice strange behavior as you navigate the system – 
changes in one browser window affect the other. That’s because many modern web browsers (such as 
Mozilla Firefox) share a single session across multiple instances. 

The safe way to access Aspen multiple times from a single computer is to use different browser 
applications. For example, login to Aspen once with Mozilla Firefox and then again with Microsoft 
Internet Explorer (rather than attempting to login twice with just Firefox). 

For the extremely hard-core (or bored) Aspen users, you can run five or more concurrent sessions of 
Aspen on a single computer by using different browser applications like Mozilla Firefox, Microsoft 
Internet Explorer, Apple Safari, Google Chrome, and Opera. 

 A Picture Is Worth a Thousand Words 

No matter how well you describe something with plain text, a picture often does the job better and 
quicker. Next time you find yourself typing a novel to describe something in Aspen, take a screenshot 
instead. Screenshots can be used for documenting a process or creating a “poor man’s backup” of how a 
page once appeared. 

There are many products on the market to capture screenshots and there’s always the old “print 
screen” option but the preferred tool of choice within X2’s Technical Services group is the FireShot add-
on for Mozilla Firefox or Microsoft Internet Explorer (http://screenshot-program.com/fireshot/). 
FireShot comes in two versions: Basic (which is free) and Pro (which costs approximately $35). The great 
news is that the Basic version has everything you need to take great screenshots of Aspen. It has 
features for: 

• Cropping 

• Drawing shapes and lines 

• Annotating with arrows and text boxes 

• Copy/pasting images into other applications like Microsoft Outlook or Microsoft Word 

• Saving images as PNG, GIF, JPG, or BMP files 

In fact, FireShot Basic was used to capture and annotate all the screenshots found in this document. 

EXAMPLE 

Rather than describing at length the options needed to run the Update Post Columns wizards, you can 
simply take a screenshot of each step and save them in a Word document. 

  

http://screenshot-program.com/fireshot/�


ASPEN’S HIDDEN GEMS v3.0 

 

X2 Development Corporation | TOP SECRET 17 

 

Notes 

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

             

   


